New Rawstudio “Daily” Ubuntu Build

We have had some problems with our build-server running out of disk space – therefore the “daily” build have been quite a lot less frequent than daily.

We have now installed a new server, and is getting it up to speed, and this means a new build:

Sorry to have kept you waiting, and even forced some of you to install build tools – we’ll try to keep this a bit more up-to-date from now on.

Download and install Rawstudio daily from here.

Update: It seems like we have to celebrate our new build system by having completely broken Nikon. The next build will fix that of course. Irony at its best. ;)

Update 2: It seems that the daily build system is actually working, so now you should get the fixed version.

Comments (5)

5 Responses to “New Rawstudio “Daily” Ubuntu Build”

  1. Wes says:

    Hello,
    I probably don’t understand the daily builds, but I’ve added the PPA in ubuntu 10.04, but don’t see the daily build version 3461 in synaptic? I’m only showing 3251. I’ve noticed the latest updates on the launchpad site say “failed to build” could this be why?

    Thanks

    • Anders Brander says:

      Build for Lucid (10.4) is working as expected. Latest version is “3461+252-0ubuntu1~lucid0″. In fact I currently don’t see any package matching version 3251 in our PPA.

      Do you keep your system up-to-date?

      Will this change anything:
      $ sudo apt-get update
      $ sudo apt-get install rawstudio-daily

      • Wes says:

        Sorry for the slow reply, I’ve been on travel quite a bit as of late. Anyways, I tried your suggestions, but it still says i have the latest version.

        Like zoomer and Klaus mentioned, the page https://launchpad.net/~rawstudio/+archive/ppa/+packages shows that the daily builds have failed.

        Anyways, I did notice that the build that I have, 3251, shows a color cast on my pentax k20d raw files, so I was hoping to see if it was different with the latest version.

  2. zoomer says:

    There’s no build 3461 for amd64 in the repository.

    I’ve checked ‘view package details’ and am64 (and i386) is signed by red cross, more details and I’ve got this:

    Build status

    [MANUALDEPWAIT] Dependency wait on americium (virtual)

    * Missing build dependencies: liblensfun0-dev
    * Started on 2010-07-07
    * Finished on 2010-07-07 (took 3 minutes, 35.9 seconds)
    * buildlog (3.0 KiB)

    • Klaus Post says:

      Yes – I got the same problem when trying to compile on Ubuntu 10.04 recently. Seems like the package is now called “liblensfun-dev” or something like that.

Leave a Reply

Klaus Post on July 5, 2010

RSS feed